Moodle soll auf dem Hauptserver von Skolelinux installiert werden

Eine hilfreiche Anleitung

http://docs.moodle.org/en/Step-by-step_Install_Guide_for_Debian#Install_Postgresql_.28skip_MySQL.29

Erfahrungen beim Installieren auf Debian-Edu Etch

Die Neuauflage des Test-Images in RLP soll moodle enthalten, und zwar so, dass es an die LDAP Datenbank angebunden ist.

Reihenfolge beachten

Apache2 ist schon installiert.

postgres8 installieren

Wir nehmen postgres8 als Datenbank, weil auch x2go und Linux4Afrika eine postgres DB benutzt.

Achting /!\ ein apt-get install moodle würde postgres7 installieren!

moodleuser anlegen

Wir legen einen moodleuser an, der die Datenbank benutzen darf.

# su - postgres
$ createuser -D -A -P moodleuser
$ exit

Wir merken uns das Passwort!

Jetzt erzeugen wir die Datenbank moodle für den moodleuser

# su - postgres
$ createdb -E utf8 -O moodleuser moodle
$ exit

Wir sichern jetzt die postgres Datenbank mit einem guten Passwort ab.

# su - postgres
$ psql template1
# ALTER USER postgres WITH PASSWORD 'HierNeuesAdminPasswortEintragen';
# \q
$ exit

Jetzt ändern wir eine Stelle in '/etc/postgresql/8.1/main/pg_hba.conf'

In der Zeile 79 ersetzen wir die beiden Worte ident sameuser durch md5:

Jetzt starten wir die Datenbank neu:

# /etc/init.d/postgresql-8.1 restart

Wir installieren moodle

Mit Debian-Etch kommt eine moodle Version 1.6. Diese ist nicht mehr sinnvoll. Wir installieren diese, um sie dann gleich mit der neuen Version zu ersetzen.

Achtung /!\ aptitude install moodle würde postgres7 mitziehen.

Wir haben das so gelöst:

apt-get -u install moodle

Wir brauchen die config.php davon.

Wir holen die neue Version:

cd /var/www/

cp moodle/config.php .

rm -rf moodle

mkdir moodle

cd moodle

wget http://download.moodle.org/download.php/stable19/moodle-weekly-19.zip

cd ..

chown -R www-data:www-data moodle

Konfigurationsdateien

/etc/moodle/apache.conf

und

/var/www/moodle/config.php

KurtGramlich/Moodle (zuletzt geändert am 2013-11-03 12:10:35 durch anonym)

Alle Inhalte in diesem Wiki stehen unter der GPL.